search cancel

Error publishing KB

book

Article ID: 257751

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

We have an inconvenience when publishing a knowledge document,  it does not allow changing the status of the document, and therefore they cannot be created for end users

During the attempt to publish, end user will select a given Document Owner, but the Publish button itself does nothing 

Environment

Release : 17.3

CA Service Desk Manager

Cause

Faulty customisation was detected which was preventing KB publish functionality.

Resolution

Existing kd_attributes_tab.htmpl was found to been modified to remove a reference to the OWNER_ID field, which the backend detail_KD.js requires.  Removed the kd_attributes_tab.htmpl from the site/mods location