search cancel

12.3 ApplicationInterface uc4.jar connecting to 21.0 error: Different versions on server (21.0) and client (12.3.).

book

Article ID: 257706

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

When using a 12.3 uc4.jar file (of version 12.3.8 or earlier) to run the Application Interface (sometimes called java api) connecting to a 21.0 CP throws the following error:

java.io.IOException: Different versions on server (21.0) and client (12.3.).
    at com.uc4.communication.Connection.<init>(Connection.java:312)
    at com.uc4.communication.Connection.loadBalancing(Connection.java:638)
    at com.uc4.communication.Connection.open(Connection.java:515)
    at com.uc4.communication.Connection.open(Connection.java:445)
    at com.uc4.communication.Connection.open(Connection.java:422)
    at CreateJob1232_to_2104.CreateJob1232_to_2104(CreateJob1232_to_2104.java:61)
    at CreateJob1232_to_2104.main(CreateJob1232_to_2104.java:51)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at edu.rice.cs.drjava.model.compiler.JavacCompiler.runCommand(JavacCompiler.java:272)

Environment

Release : <= 12.3.8

Resolution

Only 12.3.9 HF2 Application Interface can connect to 21.0.4.  Recompile any java programs to use the 12.3.9 HF2 uc4.jar file.