DriversDB package unavailable error: "Unable to update the distribution points for the package. Reason: {0}"
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DriversDB package unavailable error: "Unable to update the distribution points for the package. Reason: {0}"

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Article ID: 257603

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Updated On:

Products

Deployment Solution

Issue/Introduction

Noticed that Package Servers are unable to download the Deployment Solution package DriversDB. This package is used by DeployAnywhere to store drivers.

In at least one instance of the issue, Package Servers showed the size of the package as 0.00 KB. In another instance of this issue, the codebases for the package were not being published.

If "Update Distribution Points" is selected for the package, an error similar to the following might be seen:

Unable to update the distribution points for the package. Reason: {0}

Environment

DS 8.x

Cause

In at least one instance of this issue, it was discovered that the package reference location on the SMP in the following location was missing: \Program Files\Altiris\Notification Server\NSCap\bin\Deployment\DriversDB.

The DriversDB folder found in \Program Files\Altiris\Notification Server\NSCap\bin\Deployment\DriversDB should be a symbolic linked folder over to the actual source location of stored drivers found in \Program Files\Altiris\Deployment\DriversDB.

Resolution

In the event that the symbolic link folder is missing but the source location still holds the drivers, the DriversDB symbolic link folder can be recreated by using 'mklink' in an administrator command prompt on the SMP. This may also require logging in to the Notification Server with the application identity credentials. The following commands below are given as example only and should be verified before running:

REM Change directory to the install directory and location of the required symbolic link folder
cd \Program Files\Altiris\Notification Server\NSCap\bin\Deployment
REM Make a symbolic link folder called DriversDB that points to \Program Files\Altiris\Deployment\DriversDB
mklink /j /d DriversDB C:\Program Files\Altiris\Deployment\DriversDB

Once the link is created, verify that the "Update Distribution Points" for the package works as expected and that the Package Servers download a valid package. If the source DriversDB package is lost and the above steps are not possible, please contact Broadcom Technical Support for further assistance.