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New AD Users are not associated to the proper AD Groups in Spectrum OneClick

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Article ID: 257582

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Updated On:

Products

CA Spectrum DX NetOps

Issue/Introduction

When a new AD User logs into Spectrum, the AD User is automatically created as expected. However, in the Users tab in OneClick, the User is not getting associated to the proper AD User Group. Because the User is not getting associated to the proper User Group, they do not have permissions in OneClick.

Environment

Release : 21.2.6 and above
Component: OneClick

Cause

Upon investigation, the customer had 3 OneClick systems. On two of the OneClick systems, we see the User in question associated the proper User Group and they have permissions when logging into these two OneClick systems.

It is only on this one OneClick system where we see this issue.

It was also found that the Users that could log into this OneClick system experienced slow performance.

The root cause of the issue is credited to the slow performance of this OneClick system not getting updates from the SpectroSERVER system as expected.

Resolution

In this instance, the slow performance of the OneClick system was attributed to a lack of memory.

Additional memory was added to the system and the OneClick WEB Server Memory was increased.

After the memory was added, we did the following:

- Shutdown tomcat and web tomcat

- Removed the $SPECROOT/tomcat/work directory

- Started tomcat

- Started web tomcat

The User was now associated to the correct User Group and was able to login to OneClick without issue.

Additional Information

If you are not sure of a performance issue, please open a case with Spectrum Support for assitance.