IAM not getting started - Error during startup: java.lang.RuntimeException: Failed to connect to database
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IAM not getting started - Error during startup: java.lang.RuntimeException: Failed to connect to database

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Article ID: 257558

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Updated On:

Products

Service Virtualization

Issue/Introduction

IAM not getting started. Getting below error, attached server.log for reference

FATAL [org.keycloak.services] (ServerService Thread Pool -- 60) Error during startup: java.lang.RuntimeException: Failed to connect to database
    at org.keycloak.connections.jpa.DefaultJpaConnectionProviderFactory.getConnection(DefaultJpaConnectionProviderFactory.java:391)
    at org.keycloak.connections.jpa.updater.liquibase.lock.LiquibaseDBLockProvider.lazyInit(LiquibaseDBLockProvider.java:65)

ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 36) WFLYCTL0403: Unexpected failure during execution of the following operation(s): []: java.lang.RuntimeException: WFLYCTL0195: Interrupted awaiting transaction commit or rollback
        at org.jboss.as.controller.ParallelBootOperationStepHandler$ParallelBootTransactionControl.operationPrepared(ParallelBootOperationStepHandler.java:458)
        at org.jboss.as.controller.ModelController$OperationTransactionControl.operationPrepared(ModelController.java:131)
        at org.jboss.as.controller.

Environment

All supported DevTest releases.

Cause

IAM DB in use was decommissioned without prior notice to DevTest team.

Resolution

After pointing the IAM to another DB, the issue was resolved.