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DX APM - [ERROR] [Manager] Agent authentication token not found in secure store!

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Article ID: 257551

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Updated On:

Products

CA Application Performance Management SaaS

Issue/Introduction

An EM log of a tenant is reporting the below error continuously. What could be the reason?

172773 11/04/22 03:24:15.339 AM GMT [ERROR] [Acceptor Helper 4] [Manager] Agent authentication token not found in secure store!
172774 11/04/22 03:24:15.894 AM GMT [ERROR] [Acceptor Helper 6] [Manager] Agent authentication token not found in secure store!
...

Environment

DX APM 2.x and SaaS

Cause

Analysis from APM Development:

"The password configured in the agents must be "WilyAgent1234" for CloudProxy to correctly replace it with a valid token. Customer's agents have something else in the configuration, empty string doesn't work either"

Resolution

You must correct the default password in Agent side to be "WilyAgent1234"

 

Additional Information

https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/dx-apm-agents/SaaS/deploy-and-configure-dx-apm-agents/migrate-agents-using-cloud-proxy1.html