search cancel

Policy Manager fails to connect to gateway after upgrade to 10.1

book

Article ID: 257513

calendar_today

Updated On:

Products

CA API Gateway

Issue/Introduction

When using Policy Manager from 10.0 connecting to 10.1 it fails to connect if you choose button Generate report 

And review the exception report you see a failure of, 

WARNING: <html><center><b>Cannot connect to the gateway dummyhostname.</b>

<br> Please check your connection settings and application log for details.<br>

If the problem persists, please contact your network administrator.</center></html>
org.springframework.remoting.RemoteAccessException: Could not deserialize result from HTTP invoker remote service [https://securespangateway/ssg/manager/AdminLogin]; nested exception is java.lang.ClassNotFoundException: org.hibernate.collection.internal.PersistentBag

Environment

Release : 10.1

Resolution

You should ensure that the policy manager utilized is the same as the upgraded application. As JDK is upgraded between versions certain expected class and functions may mismatch.

So ensure you use a 10.1 policy manager to connect to policy manager 10.1.