CA Directory DXSERVER down for more than 7 days - now I cannot start it
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CA Directory DXSERVER down for more than 7 days - now I cannot start it

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Article ID: 257480

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Updated On:

Products

Autosys Workload Automation

Issue/Introduction

EEM servers were down a month or two (in a DR env for example) - and during startup the error is "dxserver down for more than 7 days"

Cause

When CA Directory dxserver is in a Multi-Write (HA) cluster, if one of the nodes is down for too long, it will not start normally. A recovery needs to be done.

Resolution

There are a few options:

Option1:

  • Stop both EEM Server's services
  • Run below command as the Unix user dsa (or a command prompt as Administrator on Windows):
    dxdisp  itechpoz
  • This needs to be done on all the EEM nodes in question
  • The command just goes back to the command prompt again  (without success / failure message output)
  • Start primary EEM's directory first, once it starts start the secondary

Option 2:

 

Additional Information

Additional questions:

Question 1: I start EEM as root usually – should I be starting dxserver as dsa?
Answer:
dxserver  ==>  gets started as  unix user dsa
iGateway =>   gets started as root



Question 2: What is dxdisp? What does it do? Why did it work?
Answer: dxdisp document