search cancel

Applying PTF LU04100 that requires COBOL V6.2 runtime support

book

Article ID: 257453

calendar_today

Updated On:

Products

SYSVIEW Performance Management Option for DB2 for z/OS

Issue/Introduction

In the apply of PTF LU04100 there is the following ++HOLD (LU04100) statement. 

+----------+-----------------------------------------------------------+
|PURPOSE   | The COBOL source code in Sysview for Db2 (IDB2) has been  |
             migrated to COBOL version 6.2. PRF requires that you      |
|          | perform the following steps:                              |
|          |                                                           |
|          | 1. Install COBOL V6.2 runtime support as described in     |
|          |    IBM APAR PI84517.                                      |
+----------+-----------------------------------------------------------+
|USERS     |All who use the DBGEXRPT utility to report the contents    |
|AFFECTED  |of the Exception Definition file.                          |
+----------+-----------------------------------------------------------+ 

The COBOL version is still V5, but the DBGEXRPT utility is not used. 
  
Will all the other features in SYSVIEW for DB2 work with COBOL V5?

Environment

Release : 20.0

Resolution

The DBGEXRPT utility is the only COBOL program shipped with SYSVIEW for DB2.

All other features of the product are unaffected.