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Scheduled reports did not run in NetOps Portal

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Article ID: 257153

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

I have scheduled reports set up in PM to go out the first of every month. I noticed today that I did not get those reports. The reports we showing last run time of December 1st 2022. I edited them so the could go out today at 1,1:15 and 1:30pm est. So far they have been stuck at calculating for over an hour. 

DX NetOps Performance Management Portal web server scheduled reports failed to run.

Dashboard Reports set to be sent via email to end users are not received.

Scheduled Reports in NetOps Portal did not run as expected.

Environment

All supported DX NetOps Performance Management releases

Cause

User that owned the scheduled report was set to Disabled.

Resolution

A scheduled report first checks the user that owns it to confirm it's a valid enabled user before running. If the user is set to Disabled it will not run.

Enable the user to allow the reports to run.

Alternatively upgrade to 22.2.2 or newer releases. This brings the new feature that allows ownership changes for reports owned by deleted users. See the Features and Enhancements 22.2.2 documentation topic for additional information.

Additional Information

If the user being enabled is considered a security risk we recommend changing the users name and password in order to maintain it's Enabled state.

If that is insufficient it leaves only two choices.

  • Upgrade to 22.2.2+ to allow moving the reports to a new user.
  • Replicate the reports (manually), along with recreating their schedules, using a valid user before deleting the old user.