search cancel

Symantec Directory : Upgrade fails with various errors

book

Article ID: 257138

calendar_today

Updated On:

Products

CA Directory

Issue/Introduction

Upgrading Symantec Directory from version 14.1.02.16555 to 14.1.04.17620, with command "./dxmgmtuisetup.sh -dxuser abc001" fails with the following error.

============================= DXSERVER QUESTIONS ==================== ===========
/tmp/cadir_rnd1648/management-ui/install/dxsetup.shlib: line 421: [: 16555: unary operator expected
   Current installed version of Symantec Directory:
   Version 14.1.02.16555
   This setup will upgrade it to:
   Version 14.1.04.17620
   Do you want to upgrade it? (and/n) [and] and
   Checking for existing abc001 account...
   The etrdir group needs to be created.
   Enter a GID for etrdir, or leave blank to accept the system default []
groupadd: group 'etrdir' already exists
   DXgroupadd failed to add group etrdir. Please check.
   Could not create the etrdir group
   Installation finished.
#####################################

You had verified that the group already exists on the host/node since it is linked from LDAP, as well as tested with locally creating this user 'abc001' and it still fails to install/upgrade.

i.e. after creating the user locally on the node, you see the following:

   Checking for existing abc001 account...
   The etrdir group needs to be created.
   Enter a GID for etrdir, or leave blank to accept the system default [] etrdir:3026
   Please enter a valid number.
   Enter a GID for etrdir, or leave blank to accept the system default [] etrdir:1001
   Please enter a valid number.
   Enter a GID for etrdir, or leave blank to accept the system default [] 1001
groupadd: group 'etrdir' already exists
   DXgroupadd failed to add group etrdir. Please check.
   Could not create the etrdir group

Next you tried to install/upgrade as a 'root' user and that also fails with different error such as:

./dxmgmtuisetup.sh -dxuser abc001

/products/cadirectory/TLC3/Software/cadir14.1.04/26505715/management-ui/install
   or one of its parent directories is not readable/executable
   Trying /tmp/cadir_rnd12158

/products/cadirectory/TLC3/Software/cadir14.1.04/26505715/management-ui/install/dxprepare.shlib: line 117: /tmp/cadir_rnd12158/management-ui/install/passwdtool: Permission denied
mkdir: missing operand
Try 'mkdir --help' for more information.

  cannot create home directory for abc001

OR the follwing message:

./dxmgmtuisetup.sh -dxuser zuh00021

/products/cadirectory/TLC3/Software/cadir14.1.04/26505715/management-ui/install
   or one of its parent directories is not readable/executable
   Trying /tmp/cadir_rnd9574

/usr/bin/id: cannot find name for group ID 3026

/products/cadirectory/TLC3/Software/cadir14.1.04/26505715/management-ui/install/dxprepare.shlib: line 117: /tmp/cadir_rnd9574/management-ui/install/passwdtool: Permission denied
mkdir: missing operand
Try 'mkdir --help' for more information.
  cannot create home directory for abc001

Environment

Release : 14.1

Resolution

You may has 'noexec' permission set on /tmp directory. Try removing this 'noexec' permision on /tmp and it should work as expected to install/upgrade with user 'abc001' or as a 'root' user.