Email address not being passed properly to CA-Spool when using SARBCH job
search cancel

Email address not being passed properly to CA-Spool when using SARBCH job

book

Article ID: 257064

calendar_today

Updated On:

Products

View Deliver Spool

Issue/Introduction

We are working with CA View reports that were sent to View by Deliver. We are performing SARBCH /EPRINT functions against these reports, so that they can be picked up by CA Spool and sent to the users via Spools email functionality. 

The problem is that the TSO userid is being substituted in place of the email address from the View/Deliver DIST ID definition. 

Environment

View, Deliver, Spool, SARBCH, 14.0, email, cssmtp

Cause

As documented in the "Email Output" section of View documentation

Preliminary Considerations
Note the following considerations:

- You can email View or archived Deliver output in online mode, but not in batch. (i.e. Not via SARBCH)

Resolution

As a workaround, in your SARBCH /EPRINT control statement, you can try to pass the email parameters to Spool using the ADDRESS keyword.

For example:

/DBASE NAME=your.view.db                                          
/EPRINT ID=reportid ADDRESS=('TO=user@domain',
    'FILENAME=reportid.PDF')                                    
    DIST=(distid/spoolnode)

Whereas, in the above example:

- The ID keyword points to the report id
- The DIST keyword points to the distid
- The value after the @ in the email address is the actual email "domain"
- FILENAME can be anything in fact but it has to end with .PDF for the report to be converted to PDF.