UVMS Filesystem full due to huge .dat file in uvmsdb folder related to UNI_UV_USERSETTINGS
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UVMS Filesystem full due to huge .dat file in uvmsdb folder related to UNI_UV_USERSETTINGS

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Article ID: 256955

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Updated On:

Products

CA Automic Dollar Universe

Issue/Introduction

Suddenly, the UVMS filesystem was full due to a huge .dat file that increased abnormally to several GB, like below:

<uvms>/data/data/uvmsdb/seg0/

-rw-r--r--. 1 username groupname 2.9G Nov 21 08:19 c1060.dat

The file could increase 1 GB each week for no clear reason.

No particular operation was done at the UVMS level.

While reading the file with a text editor, it seems that the file contained the content of the table UNI_UV_USERSETTINGS, but this table only contained 3 rows, so the size is completely abnormal.

Environment

Release : 6.9 and superior

Component: UVMS using the Internal Derby Database

Cause

Unknown, most likely a Derby database bug.

Resolution

Workaround to reduce the DB size:

There are different procedures UVMS installed on Unix or Windows:

Unix:

The  reorganization procedure for the table UNI_UV_USERSETTINGS is the following:

  • Stop UVMS: in the folder <uvms>/data execute:
    •  . ./unienv.ksh
  • then in <uvms>/app/bin execute:
    •  ./unistopms
  • Copy, backup or archive the folder uvmsdb while keeping the original folder uvmsdb in place. For instance, copying can be done like this: in <uvms>/data/data execute:
    •  cp -R uvmsdb uvmsdb_<dateYYYYMMDD>
  • Check the size of the DB: in  <uvms>/data/data execute:
    • du -hs uvmsdb
  • Execute the command 'uniderby' in <uvms>/app/bin to do the actually reorganization:
    ./uniderby -q "call SYSCS_UTIL.SYSCS_COMPRESS_TABLE('SA','UNI_UV_USERSETTINGS', 0);"
  • Recheck the size of the DB, in  <uvms>/data/data execute:
    • du -hs uvmsdb
  • Restart UVMS: in <uvms>/app/bin execute:
    • ./unistartms

Test if UVMS is working correctly for some time. If this is the case the copy of the DB can be archived and removed from the filesystem to regain the space.

 

Windows:

  • Stop UVMS: in the folder <uvms>\data\ execute:
    •  unienv.ksh
  • then in <uvms>\app\bin execute:
    •  unistopms
  • Copy or backup the folder uvmsdb while keeping the original in place in Windows Explorer.
  • In the file <uvms>\app\bin\uniderby.bat comment the line 'echo READONLY ON; >> %SQLFILE%'
    • rem  echo READONLY ON; >> %SQLFILE%
  • Execute the following command in <uvms>\app\bin\:
    • uniderby -q "call SYSCS_UTIL.SYSCS_COMPRESS_TABLE('SA','UNI_UV_USERSETTINGS', 0);"
  • Reedit <uvms>\app\bin\uniderby.bat removing the 'rem' added above.
  • Restart UVMS: in <uvms>\app\bin execute:
    • unistartms

Test if UVMS is working correctly for some time. If this is the case the copy of the DB can be archived and removed from the filesystem to regain the space.