New From Template is not showing correct fields which are configured on blueprint > Create from Template tab
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New From Template is not showing correct fields which are configured on blueprint > Create from Template tab

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Article ID: 256723

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

 

After clarity upgrade to 16.1.0 we are facing an issue on Project creation through "New from Template" some fields which are configured on Blueprint > Create from Template are not visible while trying to create project by using that blueprint.

 

 

Environment

Release : 16.1.0

Cause

Missing fields in new from template popup that are specified for create from template on new from template

Steps to Reproduce: 
1- Create a new Project Blueprint
2- Create from Template Tab
3- Add fields:
Business Project Type    - Static Lookup
Client Name - Dynamic Query Lookup
Client Type        - Static List
Client Segment/Subregion    - Parameterized Lookup
Client Country - Dynamic Query Lookup
Functional Practice 1    - Parameterized Lookup
Engagement Type 1    - Parameterized Lookup
Soutions/Set Plays 1     - Parameterized Lookup
Sell-in Date    -     Date

3- Publish the Blueprint
4- Edit an existing project to have this blueprint and to be a template
5- Create a new project from template.

Popup is missing these fields:
Business Project Type    - Static Lookup
Functional Practice 1    - Parameterized Lookup
Engagement Type 1    - Parameterized Lookup

Expected Results: New Project From Template popup displays all fields from the blueprint

Actual Results: Not all fields are displayed

Workaround: 
none

Resolution

A 3rd party blueprint migration tool was used to export a blueprint from 16.0.3 to 16.1

There are some data differences and the blueprint was corrupted.  

This is not advisable and is not supported.