Missing Software Package Library folder in DSM Explorer
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Missing Software Package Library folder in DSM Explorer

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Article ID: 256697

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation CA Client Automation - Software Delivery

Issue/Introduction

After a reinstallation of Domain Manager using the file DSMRecovery.ini some problems are seen :

- Missing Software Package Library folder

 

- DSM Reporter could not be opened and following errora appear :

The ITRMReporter plugin cannot be loaded because the [PluginDLL] registry entry is missing
 
No plugins using language ENU can be found/loaded.
 

- Registration of Software Package Job to scalability servers remain in status "SW Delivery Ordered"

Environment

Client Automation 14.5 with CU patch installed

Cause

This problem occurs if DSM Manager is reinstalled using DSMRecovery.ini using DSM Manager files 14.5 with a patch CU installed.
Some files are more recent than original files from 14.5 iso and so installation of some components are skipped during re-installation.
 
This is causing some missing entries in HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\ComputerAssociates and PATH C:\Program Files (x86)\CA\SC\DTS\bin\ is not added in System PATH environment variable

Resolution

1- Download attached file ca_correction.txt on Domain Manager
 
2- If Client Automation is not installed under default path (C:\Program Files (x86)\CA), edit this file with notepad and replace all occurrence of C:\\Program Files (x86)\\CA by the valid installation PATH.
Example :
If Client Automation is installed under D:\Program Files (x86)\CA, replace all C:\\Program Files (x86)\\CA by D:\\Program Files (x86)\\CA
 
3- Rename the file ca_correction.txt as ca_correction.reg.
Double click on it to import the registry keys
 
4- Execute systempropertiesadvanced.exe to open System Properties.
Click on "Environment Variables" button
Under System Variables, doble click on Path and click on NEW to add a new PATH for C:\Program Files (x86)\CA\SC\DTS\bin\  (adapt the PATH with the correct installation path).
 
 
 
Click OK and Apply to save the changes
 
5- Open a new cmd and restart caf :
caf stop
caf start

Attachments

1671721679568__ca_correction.txt get_app