Connector XPress 2.0 does not start
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Connector XPress 2.0 does not start

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Article ID: 256387

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Updated On:

Products

CA Identity Suite

Issue/Introduction

After installing Connector XPress 2.0 and running the "connxp start" command Connector XPress 2.0 web interface is not available

 

Environment

Identity Manager 14.4.x

Cause

Looking at the Microsoft Services (services.msc) the "Symantec IGA - Connector Xpress MongoDB" service is not available.

Resolution

Open the command prompt and run the command below, pay attention to changing the Connector Xpress path if you are not using the default installation folder:

"C:\Program Files\CA\Identity Manager\Connector Xpress 2.0\db\bin\mongod.exe" --config "C:\Program Files\CA\Identity Manager\Connector Xpress 2.0\db\mongod.cfg" --install --serviceName "ConnXP-MongoDB" --serviceDisplayName "Symantec IGA - Connector Xpress MongoDB" 

 

If you get an error message about missing DLLs (MSVCP140.dll and VCRUNTIME140.dll) you must install the "Microsoft Visual C++ Redistributable"

 

To install it, download the Microsoft file for your OS in the link below:

https://learn.microsoft.com/en-US/cpp/windows/latest-supported-vc-redist?view=msvc-170

 

After installing it, run the command above again or uninstall the Connector Xpress 2.0 running the "Uninstaller.exe" located under <ConnectorXpress2.0>/_uninst folder and install it again.

 

Run the "connxp.bat start" to start the services and open the Connector Xpress 2.0 accessing the URL

http://<host_name>:<Web UI Port>/connxp/index.html

Example:
http://192.0.2.1:20421/connxp/index.html