Unable to View Patch Management Compliance Reports in the Symantec Management Platform Console
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Unable to View Patch Management Compliance Reports in the Symantec Management Platform Console

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Article ID: 256340

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

Console users are receiving a pop up when trying to view compliance reports in the console:

Error updating content for regionContentHolder_MyReportView_1_ViewPanel: Cannot Read Properties of Null (reading 'textContent').

This error is only being received when attempting to view 'Compliance by Bulletin, Compliance by Update, and Compliance by Computer. Other console menus and settings are unaffected.

Environment

Release: 8.x

Cause

Old computer system with non-text character in Operating System field of the basic inventory data class Inv_AeX_AC_Identification

Resolution

We found the problem computer by running this query:

select distinct
    id.[OS Name],
    id.Name as 'Computer'
from Inv_AeX_AC_Identification id
order by 1

After reviewing the computer, we identified it as an old system that had not been on the network in years. We searched for and deleted the system from Manage > Computers, and then all of the patch compliance reports ran successfully. 

Note in this case the computer showed a symbol (square) for Operating System.