Unable to save a Communication Profile error- Package Compression failed
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Unable to save a Communication Profile error- Package Compression failed

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Article ID: 256335

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

Trying to follow the instructions to re-tirgger the creation of the HTTP/HTTPs packages, but when trying to save the configuration profile, I get a message below. 

Failed to re-generaet pull install packages. Please re-configure them from Default Setting on Agent Install page.
Failed to save communication profile. Reason: Package compression failed.

Package compression failed with erorr 32.
Error executing Task  (901eaaf6-6f6a-4d8f-a192-1ef59c6ea82f). Exception: System.Exception: Package compression failed.
Failed to generate packages for pull install:
Package compression failed.
Unable to load the profile settings
Package compression failed.

Environment

ITMS 8.x

Cause

Anti Virus was preventing access to needed files.

Resolution

Disabled Anti Virus and the Communication Profile was able to be saved.

Suggested adding this location to the Excludes in Anti Virus: C:\Program Files\Common Files\Altiris .  There's a 7z.dll in that folder that we use to recreate the HTTP/S installers. 

Additional Information

AeXNSCHTTP.exe and HTTPS.exe installers are located in the NSCap folder (C:\Program Files\Altiris\Notification Server\NSCap\bin\Win32\X86) and are recreated under certain circumstances.  The easiest way to recreate them is to uncheck a box the SMP Communication Profile, put the check mark back, and then save it.