search cancel

NEWCOPY of SYSVIEW load modules

book

Article ID: 256267

calendar_today

Updated On:

Products

SYSVIEW Performance Management

Issue/Introduction

Upgrading from SYSVIEW 15.0 to 16.0, having a question regarding the ‘NEWCOPY’ of the load modules.

Currently trying to ‘NEWCOPY’ the ‘GSV*’ programs most responses are NORMAL but getting the errors: 

‘NOT FOR HOLD’ and ‘CANNOT NEWCOPY’. 

Might the same errors be encountered when updating the SYSVIEW run-time library with 16.0 modules and doing a NEWCOPY of "GSV*" programs?

Environment

SYSVIEW 15.0 & 16.0 & 17.0 - z/OS supported releases - 

Resolution

About the NEWCOPY: 

SYSVIEW programmatically issues NEWCOPY for the programs during startup, except for GSVCGSVS because that is the one that does the NEWCOPYs. 

That is why the instructions only say to NEWCOPY GSVCGSVS.

The others may be in use while SYSVIEW is up.