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Unable to perform API request due to duplicate alias error

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Article ID: 256261

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

 

I am not able to perform the following API request:

POST https://bhpamadm.intranet.fw/cspm/apidoc/explorer/index.html?locale=en#!/devices/createTarretrieveAccounts

BODY:

{"accountName": "pimsos","aliasNames": "PPP-mw409opm-pimsos","attributes":{"passwordChangeMethod": "USE_SUDO"},"cacheBehavior": "useCacheFirst","cacheDuration": "30","description1":null,"description2":null,"password":"Password123","passwordViewPolicyId":"1000","privileged": "f","synchronize": "t","useAliasNameParameter": "t"}

This is the error messages

{

  "error": {

    "code": 400,

    "message": "Bad Request: PAM-CMN-0467: A Password Authority problem prevented completing the request. Message: PAM-CM-0579: Error. Attempt to create a duplicate entry. AddTargetAliasCmd.addTargetAlias insert fail, duplicate entry Check log for details."

  }

}

We are not able to understand which is the duplicated resources that the error specify

 

 

Environment

Release : 3.4.6 CAPAM 4.0.2.04

 

Cause

WE need to check if the duplicate alias error message is right, if so another alias should be used

Resolution

AS per the error message AddTargetAliasCmd.addTargetAlias insert fail, duplicate entry Check log for details

WE checked alias to see if really the error
message is true and you have some alias duplicated or not

In PAM GUI
    Credentials
    Manage Target
        Aliases

WE realize that yes, the alias trying to put in the api already belong to another hostname so was duplicated.

After changing alias name api works fine.