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NetOps Portal upgrade asks for MySql DB root user password

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Article ID: 256136

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Updated On:

Products

CA Performance Management - Usage and Administration DX NetOps

Issue/Introduction

While attempting the 22.2.4 upgrade the PC installer is asking me for root pw to mysql. I've tried every one I know and that used to be on this MySQL and none work. Need some help to get PC upgraded.

The DX NetOps Performance Management installer is asking for a database password for the root user during an upgrade. This is not a normal expected question. When the correct complex MySQL password is entered the result is rejection. The installer just returns a password rejection saying it's not valid. No more specific error is seen.

Attempts to connect to MySQL independent of the running services, using CLI tools, also fail. This is despite use of the known correct password. An example of the error from attempts to connect to the MySQL CLI look like this.

The Portal server involved was running for over 200 days without reboot.

Environment

All supported DX NetOps Performance Management releases

Cause

The MySQL /tmp/msyql.sock file was removed from the system after the MySQL service was started.

No specific reason for the file being removed is known. Being placed in /tmp suggests some cleanup process, or possible user interaction resulted in the file being removed.

Resolution

The /etc/my.cnf states the socket file mysql is using is the /tmp/mysql.sock file.

If no longer present post MySQL start to resolve it we would take the following steps.

  1. Stop the four Portal web server services.
  2. Stop the MySQL service.
  3. Start the MySQL service.
    • Confirm the /tmp/mysql.sock file exists.
    • If it exists confirm MySQL connection via CLI using known password works.
  4. Start the Portal web server services.

Additional Information

See the Restart NetOps Portal documentation topic for steps to stop and start the Portal web server services and it's MySQL database.

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