search cancel

DX AIOps Installation check - How to verify the NFS version?

book

Article ID: 256075

calendar_today

Updated On:

Products

DX Operational Intelligence DX Application Performance Management CA App Experience Analytics

Issue/Introduction

As per documentation NFS 4.1 is recommended:  https://techdocs.broadcom.com/us/en/ca-enterprise-software/it-operations-management/dx-platform-on-premise/22-1/installing/Hardware-software-requirements.html

" NFSv4.1 is the required version." 

Can I verify can I am using the expected version?

Environment

DX Platform: any version

DX OI, DX APM, DX AXA: any version

Resolution

You can verify this information from the apm services-nass pod


1) connect to the pod using :

kubernetes: kubectl exec -it <podname> bash -ndxi

openshift : oc rsh <pod-name>

 

2) execute /proc/mounts as below:

cat /proc/mounts | grep nfs

Example output:

172.20.16.16:/volumes/data-store/apmservices/nass-001/data /usr/local/apmservices/nass/data nfs4 rw,relatime,vers=4.1,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=172.20.31.45,local_lock=none,addr=172.20.16.16 0 0

Additional Information

https://knowledge.broadcom.com/external/article/190815/aiops-troubleshooting-common-issues-and.html