UIM - Qos_data isn't inserting into Oracle database.
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UIM - Qos_data isn't inserting into Oracle database.

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Article ID: 256052

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

Raw data is not inserting into the database.  RN_QOS_DATA_* tables are empty; retention settings have been removing data.  The data_engine probe is configured to partition the tables, but no new partitions are being created.

The data_engine log shows the following:

de: data_engine [QoS] [QoSData] - commitDataHasMax [QoSData] data_engine [QoS] status: -1
 OCI_ERROR - ORA-14400: inserted partition key does not map to any partition

 OCIEnv: 0x0x7ff44800XXXX OCIAuthInfo: 0x0x7ff44801XXXX OCISvcCtx: 0x0x7ff44804XXXX 
 - Error: commitDataHasMax [QoSData] data_engine [QoS] status: -1
 OCI_ERROR - ORA-14400: inserted partition key does not map to any partition

 OCIEnv: 0x0x7ff44800XXXX OCIAuthInfo: 0x0x7ff44801XXXX OCISvcCtx: 0x0x7ff44804XXXX 

Environment

  • Release: 20.3+
  • Oracle database
  • data_engine 20.41

Cause

  • New partitioning is failing. Data retention settings are removing older data and new data can't be inserted as the partitions will not be created.

Resolution

Need to allow the data_engine probe to re-partition the tables:

  1. Open the data_engine probe using Raw Configure mode (select the probe then hold down the SHIFT key and rt-click to open in Raw Configure mode)
  2. Change the value of data_management_partition from "yes" to "no"
  3. Change the value of table_maintenance_loglevel=5
  4. Restart the data_engine probe
  5. Open the probe utility (Ctrl-P) for the data_engine and run the "run_admin_now" callback



  6. Check the logs and watch for the maintenance activity.

    The maintenance activity starts with the following:

    Dec  9 21:39:56:159 [11660] 1 de: Admin - start admin routines
    Dec  9 21:39:56:164 [11660] 3 de: [Admin] has connected to database

    and ends with the following:

    Dec  9 21:39:57:671 [11660] 1 de: Admin - Data Maintenance used 1 seconds ~= ( 1 second )
    Dec  9 21:39:57:671 [11660] 3 de: [Admin] has disconnected from database

    You can also check to see that the partitions have been removed from the tables.
  7. Once the tables are unpartitioned proceed on the following steps...

  8. Change the value of data_management_partition from "no" to "yes" and then restart the data_engine

  9. Run the "run_admin_now" callback again and check the logs.  You should also see data in tables.