search cancel

After Upgrade Servicepoint Server not Available Contact the Administrator

book

Article ID: 255971

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

After to upgrade SDM and Catalog from 17.3.0.15 to 17.3.0.18, ServicePoint not show the catalog offers. I ran the post instalation steps for CA Service Catalog adding the next values in web.xml

<param-name>cors.allowed.origins</param-name>
<param-value>http://usshostname:ussport,http://servicepointhostname:servicepointport</param-value>

and 

<param-name>cors.allowed.origins</param-name>
<param-value>http://usshostname:ussport,http://servicepointhostname:servicepointport</param-value>

After to restart the services, the error persist

 

Checking Task Manager Details page we only found the one microservice running on port 9444 - there should have been all the 

Environment

Release : 17.3 RU18

Cause

When looking at the installation folders for the microservices we noticed the "lib" folder was missing from the folders for collabmicroservice, insightmicroservice, pushmicroservice, and searchmicroservice.

Resolution

We went to another server where RU18 was successfully installed and created zip files of the lib files for those microservices.  We then unzipped those folders on the server with the problem, restoring the missing lib folders for those microservices.  After this we restarted xFlow and everything appears to be working now.

Root cause as to why those lib folders were missing was never found.

Attachments