search cancel

Upgrade of Linux agent (CAU) throws errors of GLIBCXX_* and CXXABI_* not found.

book

Article ID: 255969

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The Centralized Agent Upgrade (CAU) of the Linux agent throws the following version not found messages:

 /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
Hello
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `CXXABI_1.3.11' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)
/opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/automic/ServiceManager/bin/./../../Agents/linux/bin/ucxjlx6m)

Environment

Release : 21.0.x

Linux Redhat 7.9

Cause

Environment.

Resolution

The LD_LIBRARY_PATH contained the following entries:
LD_LIBRARY_PATH=/lib/:/usr/lib/:/lib64/:/usr/lib64/:/usr/libexec/:/var/lib/

 

Once this was changed in the bashrc to::
LD_LIBRARY_PATH=""

The Linux agent could be upgraded via the CAU.