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CA Mediation Manager process hangs, data collection stops

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Article ID: 255850

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Updated On:

Products

CA Mediation Manager DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

camm is locking up to the point of cammStatus wont even run on MC/LCs. If i go through and restart processes then it will recover for short period of time and hang again.  This is all post 21.2.12 upgrades to DXNetOps/DXMM last week.

DX NetOps CA Mediation Manager services are hanging and failing to remain functional. Data collection stops shortly after services are started.

Custom Device Packs are in use.

In the CAMM-Local-Controller-STD-ERROR-<DATE>.log file we see this error.

Exception in thread "Thread-416" java.lang.OutOfMemoryError: unable to create native thread: possibly out of memory or process/resource limits reached

Environment

All supported DX NetOps CA Mediation Manager releases

Cause

The ulimit value for the process owner was set to low.

Resolution

Set ulimit to 65K to resolve this. Restart CAMM services after making the change.