Unable to obtain rest access_key and getting error "404 not found" on REST Web Services after installing RU18
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Article ID: 255721
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Updated On:
Products
CA Service Management - Service Desk ManagerCA Service Desk Manager
Issue/Introduction
Issue:
After upgrading to RU 18 when trying to obtain rest_access getting 404 Not Found response.
Steps:
-> Launch Postman and give the required details and try to retrieve access_key
-> But getting Error 404 as below
Environment
Release : 17.3
Cause
This is because of the cxf-rt-bindings-soap-3.4.5.jar being shipped in to the NX_ROOT\java\lib\CXF folder of 17.3 RU18 to support SOAP CXF Webservices.
Resolution
Solution is included in 17.3 RU 19.
Workaround for RU18 installations:
Stop the CA Service Desk Manager Services.
Navigate to NX_ROOT\java\lib\CXF folder and move the file cxf-rt-bindings-soap-3.4.5.jar into the NX_ROOT\java\lib folder. IMPORTANT: Do not leave a copy of the file cxf-rt-bindings-soap-3.4.5.jar in NX_ROOT\java\lib\CXF
Navigate to NX_ROOT\pdmconf folder and back up the pdm_startup.i file and the pdm_startup.i.tpl files.
Edit the pdm_startup.i file in notepad++.
Look for the entry $NX_ROOT/java/lib/CXF/cxf-rt-bindings-soap-3.4.5.jar and change it to $NX_ROOT/java/lib/cxf-rt-bindings-soap-3.4.5.jar
Edit the pdm_startup.i.tpl file and perform the same change to modify the location of the cxf-rt-bindings-soap-3.4.5.jar