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response path jitter test show "no data to display"

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Article ID: 255683

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Updated On:

Products

CA Performance Management - Usage and Administration

Issue/Introduction

response path jitter shows "no data to display" for the previous month or last 7 days.  But when I change range to last 24hour, i can see the data

 

Environment

Release : 21.2, 22.2

Cause

The rollup failed for the Response Path Test Jitter Metric Family, and won't create a new rollup until dadamon is restarted

Resolution

restart dadaemon on the Data Aggregator, but don't restart activemq.  The Data Collectors cache data in activemq

When the Data Aggregator comes back up, the Jitter rollup queue should be processed by the DA, starting at next rollup processing (which is at least 1 hr from DA startup, we don't want to put rollup load until DA is able to fully get back to polling/etc).

Additional Information

You can check the latest timestamp in as-polled, hourly, daily and weekly data queues, in the Vertica database, as follows

select max(tstamp) from dauser.nrm_resp_path_jitter_rate;      (5-Minute data)

select max(tstamp) from dauser.nrm_resp_path_jitter_ltd;        (Hourly data)

select max(tstamp) from dauser.nrm_resp_path_jitter_eqd;      (Daily data)

select max(tstamp) from dauser.nrm_resp_path_jitter_gtd;        (Weekly data)

 

Then you'll need to convert the epoch into a date/time, using an epoch converter