search cancel

apm_bridge and oi_connector probes not starting after OS patching

book

Article ID: 255553

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

For the last few months, we have noticed that the apm_bridge and the oi_connector probes are not starting up correctly.  They are both showing the max restarts reached error until we deactivate and then active them.  They start up fine after that.  This is only happening in our production environment and not our test environment and has been the case before and after the CU5 update in our test UIM.

 

Nov 29 17:20:30:321 INFO  [main, apm_bridge] Login to NimBUS is OK
Nov 29 17:20:30:338 INFO  [main, apm_bridge] The probe connects to Primary Hub
Nov 29 17:20:30:383 INFO  [main, apm_bridge] Detected Primary Hub: /UIM/secondaryHUB/shub/hub
Nov 29 17:20:30:383 INFO  [main, apm_bridge] Detected Primary Hub: /UIM/primaryHUB/phub/hub
Nov 29 17:20:30:384 FATAL [main, apm_bridge] Exiting probe
com.uim.probe.bridge.apm.util.PrimaryHubDetectionException: The probe detected several primary hubs. Please set the address of required hub to the configuration file setup -> primary_hub_address = /<domain>/<hub>/<robot>/hub
 at com.uim.probe.bridge.apm.util.CallbackUtils.fetchPrimaryHubAddress(CallbackUtils.java:161)
 at com.uim.probe.bridge.apm.util.CallbackUtils.getPrimaryHubAddress(CallbackUtils.java:42)
 at com.uim.probe.bridge.apm.util.CallbackUtils.verifyPrimaryHubAvailability(CallbackUtils.java:283)
 at com.uim.probe.bridge.apm.APMBridgeProbe.main(APMBridgeProbe.java:127)

Nov 29 17:20:31:386 [8272] Controller: Max. restarts reached for probe 'apm_bridge' (command = <startup java>)
Nov 30 08:25:54:413 INFO  [main, apm_bridge] Manifest-Version: 1.0
Implementation-Title: APM Bridge
Implementation-Version: 1.0.6-T2-SNAPSHOT
SCM-Revision: a9465aff1c986131086f3c32ba049953f555f740
Built-By: jenkins
Implementation-Vendor-Id: com.ca.uim
Build-Time: 25.02.2022-07:07
Created-By: Apache Maven 3.5.0
Build-Jdk: 1.8.0_302
Implementation-Vendor: CA Unified Infrastructure Management
Main-Class: com.uim.probe.bridge.apm.APMBridgeProbe


Nov 30 08:25:54:493 INFO  [main, apm_bridge] Login to NimBUS is OK
Nov 30 08:25:54:516 INFO  [main, apm_bridge] The probe connects to Primary Hub
Nov 30 08:25:54:567 INFO  [main, apm_bridge] Primary Hub is available: /UIM/primaryHUB/phub/hub
Nov 30 08:25:54:574 INFO  [main, apm_bridge] UIM version: 20.4.0
Nov 30 08:25:54:581 INFO  [main, apm_bridge] ****************[ Starting ]****************
Nov 30 08:25:54:582 INFO  [main, apm_bridge] 1.0.6-T1
Nov 30 08:25:54:582 INFO  [main, apm_bridge] CA
Nov 30 08:25:54:585 INFO  [main, apm_bridge] port=48039
Nov 30 08:25:54:596 INFO  [main, apm_bridge] Has already a SID
Nov 30 08:25:54:597 INFO  [main, apm_bridge] Login to NimBUS is OK
Nov 30 08:25:56:844 INFO  [main, apm_bridge] Starting Probe with pre-configured use-case: doi
Nov 30 08:25:56:895 INFO  [main, apm_bridge] Connecting to Primary hub
Nov 30 08:25:56:895 INFO  [main, apm_bridge] with address: /UIM/primaryHUB/phub/hub
Nov 30 08:25:56:895 INFO  [TopologyService STARTING, apm_bridge] Connecting to Primary hub
Nov 30 08:25:56:895 INFO  [TopologyService STARTING, apm_bridge] with address: /UIM/primaryHUB/phub/hub
Nov 30 08:25:56:902 INFO  [APMInventoryService RUNNING, apm_bridge] Running APM Inventory Update
Nov 30 08:25:56:915 INFO  [TopologyService STARTING, apm_bridge] Queue 'apm_bridge_inventory' exists and is active
Nov 30 08:25:56:919 INFO  [TopologyService STARTING, apm_bridge] Create Topology subscription on Primary hub
Nov 30 08:25:56:922 INFO  [TopologyService STARTING, apm_bridge] Primary Hub is available: /UIM/primaryHUB/phub/hub

Environment

Release : 20.4

Resolution

Follow the requested fix from the log

The probe detected several primary hubs. Please set the address of required hub to the configuration file setup -> primary_hub_address = /<domain>/<hub>/<robot>/hub