Invalid Transaction: 'Exchange Rate for Home Currency Code not found'
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Invalid Transaction: 'Exchange Rate for Home Currency Code not found'

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Article ID: 25543

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Updated On:

Products

Clarity PPM SaaS Clarity PPM On Premise

Issue/Introduction

The Administration, Transaction Log shows entries that are rejected. How do I fix the records based on the error messages that appear? The error message shown is "Exchange Rate for Home Currency Code not found".

 

Cause

Message: "Exchange Rate for Home Currency Code not found"

This error message indicates that the "HOME" Currency code on the associated Entity properties, may not have an active Foreign Exchange Rate.

Resolution

Go to the Administration > Financial Setup > Currency Section

There are 2 links visible when CA PPM is configured for multi-currency.

  • Currency: this page allows you to activate various currency codes for use by the application

  • Foreign Exchange Rates: this page shows you all the foreign exchange rates defined for any Currency Code. You should define a matching pair of Exchange Rates. Check to make sure the effective dates cover dates for which you have financial transactions.

Another cause to this issue may be due to an invalid Department and Location OBS unit combination configured on the Project Financial Properties page.

After you make the changes described above for the errors that are generated, you can launch the 'Post Transactions to Financials' Job and the transactions will disappear from the Transaction Log, if no other rejected reason is found. The transactions will then be ready for the 'Post to WIP' action.