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Autosys upgrade failure: Failed to get security status

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Article ID: 255289

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Updated On:

Products

CA Workload Automation AE

Issue/Introduction

Autosys upgrade on the secondary server failed with the following error -

"Unable to determine the security status of the instance TST. Click ok to abort the install. Correct the instance security status and start the upgrade again."

Environment

Release : 11.3.6 SP8

Cause

The error is due to the autosys instance security in the on secondary server mismatch with the database.

Appears in the environments where the original server installation was performed with Native security and later switched to EEM.

 

Resolution

To workaround the problem,

Start the application server on primary. Run autosys_secure to switch the security to  NATIVE.

Revert to Native Security

https://techdocs.broadcom.com/us/en/ca-enterprise-software/intelligent-automation/workload-automation-ae-and-workload-control-center/11-3-6-SP8/securing/native-security-mode/revert-to-native-security.html

Add the current user (login_id) to the EDIT/EXEC users

Stop the application server and re-run the installer on the secondary to upgrade

Start the application server after the successful upgrade

Execute autosys_secure to enable the security back to EEM.

Start the rest of services

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