404 Error on Console Manager following upgrade of AP server to 11.7
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404 Error on Console Manager following upgrade of AP server to 11.7

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Article ID: 255229

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Updated On:

Products

Automation Point

Issue/Introduction

One Automation Point server has been upgraded to version 11.7 (base version) and activated console manager.  When trying to  access console manager for this server from a browser, an error 404 (file or directory not found) is received.  IIS is turned on for this server.
AP 11.7 has been installed, and Console Manager ha been activated on two other servers, and accessed them from a browser.

Questions:

1)  When Console Manager is activated, where is the site located in the server's file directory?

2) Is IIS required for Console Manager to work?   AP 11.7  does not require IIS for Console Manager to work, and another server that needs IIS.

Can you help troubleshoot this issue?

Cause

With 11.7 SP1 AP now uses NodeJS rather than IIS, which is no longer distributed.  

Resolution

IIS is no longer distributed with Automation Point 11.7 as it is no longer required 

In summary the IIS is blocking the connection and the port needs to be changed.  

As for the server's file directory, prior to AP 11.7.SP1 it would be in the Tomcat war files.  After SP1 they are in the NodeJS default location. 

NodeJS:

For the AP Alert Manager and Notification Manager website access..
Please check in the Web services if you have specified in the Trusted CORS filed the localhost or all IP access (address 0.0.0.0) as per the below:

If they are not specified, then they should be added and the AP Rest Server needs to be recycled via the Services in AP Configuration Manager, or the APNODE service in the Windows Services app.

The location of the NodeJS application of AP are still in the original location in the AP Programs Files(x86) Node directory...
And with Windows Task Manager you can see how they are executed and from what location.