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Checkout from Workbench Crashes Agent

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Article ID: 255195

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Updated On:

Products

CA Harvest Software Change Manager

Issue/Introduction

Only for certain projects on certain brokers, when the users do a checkout to the agent machine, the agent crashes and the checkout does not succeed.  No error messages or codes are returned to Workbench.  How can this be resolved?

 

Environment

Release : 13.0.3

Cause

We added agent-side logging with "-trlvl=1" and then with "-trlvl=2" in the HAgent.arg file but did not see any helpful information in the agent log files.

We tried using the "hco" command line utility with the "-tr" option and the checkout succeeded so we could not reproduce the problem that way.

Instead of checking out all the files in a package, we tried checking the files out one at a time and found that 2 of the 3 files checked out successfully and the third one caused the agent to crash every time.

Looking at the permissions and ownership of the files in the target folder on the agent machine, we noticed that the .harvest.sig file was extremely large

Resolution

Concluding that the .harvest.sig file was corrupted we deleted it and then the checkout of all files from Workbench succeeded.

Additional Information

You can read more about the harvest.sig file here: Use Check-In and Check-Out in CA Harvest SCM - Signature Files

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