Package Servers Attempting to Download to a Drive that does not exist
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Article ID: 255176
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Updated On:
Products
Client Management SuiteIT Management Suite
Issue/Introduction
Multiple Package Servers fail to download the Packages as they are attempting to save to a drive that does not exist on the server. In this case they were all trying to download to the F: drive.
Environment
ITMS 8.x
Cause
Unknown, but it's likely an F: drive existed at some point. Based on what has been seen in the past it is likely that this issue is is a result of the "drive rotation" feature.
Resolution
In this case, the agent installation drive has enough disk space for all expected packages in the Package Delivery folder of the Altiris Agent. To remedy this do the following:
Switch off the "drive rotation" feature by unchecking "Allow usage of all the fixed drives when the primary file storage location runs out of disk space". This will avoid such situation to appear on other machines.
Settings > All Settings > Notification Server > Site Server Settings > Package Service > Package Service Settings > Site Servers > Each Server with Package Service installed > Web Configuration Section.
Note: Verify that any configured Package Servers are not overriding this global policy in Settings > Notification Server > Site Server Settings
Remove snapshot.xml and snapdata.xml files on already affected Package Servers and Refresh packages. Default location on Package Servers is C:\Program Files\Altiris\Altiris Agent\Package Delivery.
The packages then will re-download all snapshots from NS and should download faulty packages to default location.