Global Collection names are messed up on OneClick servers in Fault Tolerance configuration
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Global Collection names are messed up on OneClick servers in Fault Tolerance configuration

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Article ID: 255143

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Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

In a Fault Tolerance configuration, with many Landscapes and multiple OneClick servers, there are differences in the names layout seen in the tree on the left hand side and the tab List on the right for the Global Collections on the various OneClick servers.  

OneClick shows wrong Global Collection names. The Contents panel shows the name of an interface or RTMHost while in the Component Detail panel the name of Global Collection is properly displayed.

Same issue is seen for OneClick Java console and OneClick WebApp console and for different users including the admin user.

Environment

Version: Any
Component: Global Colelctions

Cause

This may happen when the Primary and Secondary databases are out of sync, most commonly from loading a save on the Primary with a previously saved database, which results in the model handle 0x123456 is a Global Collection on the Secondary, but an interface model on the Primary.

So when the OneClick reconnects to the Primary, the model name of the interface is displayed, instead of the Global Collection name. Hence they are listed alphabetically with the new name and so the order is messed up. 

Resolution

The resolution is to resync data between all Primary and Secondary SpectroSERVERs in the Fault Tolerant environment.

Refer to https://knowledge.broadcom.com/external/article?articleId=121446

When completed, stop tomcat and webtomcat services on all the OneClick systems, remove the $SPECROOT/tomcat/work directory, then restart the tomcat and webtomcat services.

After completing this process for all the Landscapes and the OneClick servers, all of them should be showing the correct Global Collections naming layout.