search cancel

DX UIM - HUB Compatibility - Can I have different hub versions in the same environment?

book

Article ID: 254915

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

We have 2 frontend servers that all our customers are connected

These 2 servers run HUB 9.31 and so do all of the customers, but does it work fine if we upgrade these frontend servers to HUB 9.36 and let the customers run on HUB 9.31 for a while?

The plan is also to upgrade all customers to HUB 9.36, exception of those customers who run HUB on Windows server 2008 R2 Standard Edition

Another concern is that we have some customers running Windows Server 2003 with robot 7.93 and windows server 2016 or windows server 2008 R2 or windows server 2019 with HUB 9.31, will it work for these customers to upgrade to HUB 9.36 and continue to run robot 7.93 on these old Windows Server 2003?

Will 9.31 HUB`s work without problems together with the 9.36 HUB`s?

 

Environment

Release : 20.4

Resolution

You can have different Hub versions in your environment based on your OS compatibility, even old versions.

Regarding the robot, this also will be fine.  The older robots can communicate with the newer hubs as long as the robot is installed on an OS which is supported by that version of the robots. 

So for example the old Windows 2003 server can run robot 7.93 and be attached to hub 9.36 and it should work without any issues.