CIC logs are created daily
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CIC logs are created daily

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Article ID: 254870

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

It's noticed that a CIC log with format "CIC-MM-DD-YY-1.log" are being created in a daily basis, causing that at certain point several files could be on the "logs" folder:

Environment

Client Automation - All Versions

Cause

The file that manages the log creation frequency is "log4j2.xml" located under ..CA\SC\CIC\conf

Resolution

In order to modify the rate of log creation, there are few steps that have to be followed:

1.- CIC has to be stopped, but there is no way to clearly do it when CIC is not installed as a services (which is the default). In order to create CIC service, the following can be made:

- Navigate to ..CA\SC\CIC\bin
- Double.click on "OnlineServiceInstall.bat"
- A new "CA Content Import Client" service will appear, and be sure that the service is stopped:

2.- Open Task Manager and verify that Java is running associated to CIC is running, if it is, kill the application:

3.- Modify the variables "SizeBasedTriggeringPolicy" and "DefaultRolloverStrategy" on file "log4j2.xml" with the desired values, this is an example:

4.- Start CIC service:

5.- After few days, can be seen that the CIC log file creation will be limited:

Additional Information

If it's required to decrease the log files being created even more, attached to this article you can find a .XML file that can replace the original "log4j2.xml".

Attachments

1673986051696__log4j2.xml get_app