IDM fail to start after fresh install
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IDM fail to start after fresh install

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Article ID: 254846

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Updated On:

Products

CA Identity Manager

Issue/Introduction

Seeing the folloiwing error

ERROR PBESHA1RC2CBCPKCS12PBE5128Handler org.bouncycastle.crypto.internal.io.StreamIOException: Error closing stream: 
2022-11-15 14:35:46,325 ERROR [stderr] (MSC service thread 1-4) org.bouncycastle.crypto.internal.io.StreamIOException: Error closing stream: 

ERROR [org.jboss.as.connector.subsystems.datasources.AbstractDataSourceService$AS7DataSourceDeployer] (MSC service thread 1-3) Exception during createSubject() for java:/iam/im/jdbc/jdbc/idm: PBOX00016: Access denied: authentication failed: java.lang.SecurityException: PBOX00016: Access denied: authentication failed
 at org.jboss.security.plugins.JBossSecuritySubjectFactory.createSubject(JBossSecuritySubjectFactory.java:92) 

Environment

CA Identity Manager 14.4 

Open JDK 1.8.0_292

WildFly 15.0.1.Final

RHEL 8.6

Cause

Running the Multi database tool would not update xml file with the correct SQL SA Account(s) and credentials for each DB. The file would get updated but only have the Object Store SA account for each DB connection. 

Resolution

Manually update the xml with the SA Accounts for each DB