search cancel

Process Monitoring shows wrong Agent, ST & ET for a task in graphical view

book

Article ID: 254697

calendar_today

Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

The wrong Agent is displayed when opening a task within a workflow in the graphical Process Monitoring. Only when hover over the task the correct Agent and start/end times are shown.

Steps to reproduce
  • execute a workflow that runs 2 sub-workflows in parallel but on different Agents
  • after execution open the graphical Process Monitoring
  • open in one of the first sub-workflow the first task (the correct Agent, ST & ET are shown)
  • open in the other sub-workflow the same task
Actual Results
  • the wrong Agent is show (e.g. VVIESTZ01_AGENT) and also ST & ET are wrong

  • hover over the task and the correct Agent, ET & ST are shown (e.g. VMUNCDA01-V123) in the task-box and in the information popup

Expected Results
  • the correct Agent (e.g. VMUNCDA01-V123) and correct start/end-times are displayed in the task-box and in the info-popup when hover over the task

Environment

Release : 12.3.x and 21.x

Component: Automic Web Interface (AWI)

Cause

Defect: due to incorrect caching a different execution of a task would appear in nested workflows.

Resolution

Update to a fix version listed below or a newer version if available.

Fix version:
Component(s): Automation Engine and Automic.Web.Interface (AWI)
Will be fixed in Automation.Engine 21.0.5 - Planned release February 2023

Additional Information

Solution details: A bug was fixed where due to incorrect caching of images, a different execution of a task would appear in nested workflows when the same task was running in different workflows on distinct agents.

Attachments