Jobs get Access denied pointing to row that doesn't take away access
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Jobs get Access denied pointing to row that doesn't take away access

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Article ID: 254656

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation Automic SaaS

Issue/Introduction

When running a JOBS object or other task that requires a login object, the user is seeing the following when SECURITY_AUDIT_FAILURE has OBJECT_ACCESS set on:

U00000009 'JOBS.JOB_NAME': Access denied
U00004519 Access violation details: Used filter: 'JOBS' .
U00004505 Access violation: User: 'USER/DEPT' Object: 'JOBS.JOB_NAME' Access type: 'U00909802 X' Reason: prohibition in authorization profile: 'USER/DEPT'.

The user looks like they have access to the JOBS object and everything that's needed to run it though.  There is nothing in the USER or USERGROUP objects that show why there should be an access denied error

Environment

Release : 12.3 and up

Cause

Access violation is on the Login column of the JOBS row

Resolution

Check the Logins allowed for the job by using the dropdown arrow in the upper right of the authorizations tab on the USER or USERGROUP and checking the "Login" object:

Once this is added, check that there's no Login object that is causing the problem:

Additional Information

In older versions where the Java UI was used, the Login column was shown by default.  With the switch to the AWI, this is no longer the case.  This is as designed.