Resolving Access Gateway error - [ERROR] Agent for virtual host : default did not initialized properly
search cancel

Resolving Access Gateway error - [ERROR] Agent for virtual host : default did not initialized properly

book

Article ID: 254481

calendar_today

Updated On:

Products

CA Single Sign On Agents (SiteMinder)

Issue/Introduction

"We are using R12.8 SP04. I have two servers for CA AG. We didn't make any change and I am getting this error in the logs Agent for virtual host : default did not initialized properly. "

The customer re-registered the trusted host but still getting the same issue

Environment

Release : 12.8

Cause

Reviewing the affwebserv.log revealed these messages:

[299688/140027181618944][Wed Nov 16 2022 12:11:49][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (SM_WSB_00008 - Administration Manager is trying to create configuration for the SiteMinder Agent)

[299688/140027181618944][Wed Nov 16 2022 12:11:49][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (SM_WSB_00056 - Creating agent connection using file : /app/smuser/CA/secure-proxy/proxy-engine/conf/defaultagent/WebAgent.conf)

[299688/140027181618944][Wed Nov 16 2022 12:11:50][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (SM_WSB_00046 - Registering the Configuration Manager with the Policy Server)

[299688/140027181618944][Wed Nov 16 2022 12:11:50][agentcommon][INFO][sm-FedClient-00010] sm-FedClient-00010 (SM_WSB_00049 - The doManagement Thread failed as the Policy Server could not be reached. Reason: Agent API No Connection)

[299688/140027181618944][Wed Nov 16 2022 12:11:50][FWSAdministrationManager.java][ERROR][sm-FedClient-00050] sm-FedClient-00050 (Failed to create agent configuration for : /app/smuser/CA/secure-proxy/proxy-engine/conf/defaultagent/WebAgent.conf)

Resolution

As noted by the messages, review the WebAgent.conf and verify all the information is correct. Next review the SmHost.conf and also validate the file's information. And finally, check the HCO settings for accuracy.

In this particular instance, a DNS issue was occurring, and switching the HCO to use the IP address resolved the issue.