Not able to access policy manager
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Not able to access policy manager

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Article ID: 254243

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Updated On:

Products

CA API Gateway

Issue/Introduction

In the values.yaml file, the custom feature was enabled (set the parameter to true) on the default port. The port was changed from 8443 to 443 and services were restarted. After this change, the users could not log in to the Policy Manager. The custom feature was disabled (set the parameter back to false) and the port was changed back to 8443. After restarting services, the Policy Manager is still not accessible. Reinstalling the Policy Manager did not resolve the issue. 

 

Environment

API Gateway 10.1 on Kubernetes

Cause

Per the description in the values.yaml file, the configuration for the default port was overridden. Even though the parameter was later disabled again, this did not revert the configuration of the default listen port. More than likely, the ability to log in to the Policy Manager has been removed from the port. You can check this by running the following command: mysql -e "select name, port, endpoints from connector;"

If you do not see ADMIN_REMOTE as an endpoint for port 8443, then it needs to be re-added.

Resolution

To restore the default endpoints, log in to the MySQL database and run the following command:

UPDATE connector SET endpoints = 'MESSAGE_INPUT,ADMIN_REMOTE,ADMIN_APPLET,OTHER_SERVLETS' WHERE port = '8443';
FLUSH PRIVILEGES;

You will need to restart the gateway services for the change to take effect.