Clarity Upgrade fails with "Failed to change file modification time" in install.log
search cancel

Clarity Upgrade fails with "Failed to change file modification time" in install.log

book

Article ID: 254161

calendar_today

Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

On a second attempt to upgrade Clarity, the following error is thrown:

11/09/22 7:38 AM (ExecTask) _process-install-dir:
11/09/22 7:38 AM (ExecTask) Moving 23775 files to D:\Clarity
11/09/22 7:45 AM (ExecTask) Moved 2005 empty directories to 155 empty directories under D:\Clarity_16.0.1.838
11/09/22 7:45 AM (ExecTask) Expanding: D:\Install\install-packages\16.0.2\upgrade-repack.16.0.2.861tpexcludes\package.jar into D:\Clarity
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Unable to expand to file D:\Clarity\META-INF\MANIFEST.MF
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Unable to expand to file D:\Clarity\lib\jgroups-all.jar
11/09/22 7:45 AM (ExecTask) Unable to expand to file D:\Clarity\lib\xinclude.jar
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time
11/09/22 7:45 AM (ExecTask) Failed to change file modification time

Thrown many times in the install.log

Cause

This can happen for two reasons:

  • The OS still holds a lock over the files and prevents any updates to them
  • The original Clarity folder files got corrupt by the previous install attempt

Resolution

  • Restore another Clarity folder from a backup and restart the upgrade
  • For OS locks, sometimes a server reboot would help as well