Error 1603 and Error 2318 when Inventory Agent Plug-In Upgrade Fails
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Error 1603 and Error 2318 when Inventory Agent Plug-In Upgrade Fails

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Article ID: 254092

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Updated On:

Products

Client Management Suite Inventory Solution IT Management Suite

Issue/Introduction

When attempting to upgrade the Inventory Solution Plug-in Agent, it fails with the return code of 1603.  Researching the agent logs only reveals this error as the return code and with no other failures.

Environment

ITMS 8.6

Cause

Corrupt XML files in C:\Program Files\Altiris\Altiris Agent\Agents\Inventory Agent\InvTaskConfig.  A 0 KB files shown in this directory as seen here: 

Resolution

This issue is caused by creating Inventory Policies with a colon (:) in the name.  This is an illegal character in the Windows operating system.  So therefore the file is not created correctly resulting in a 0 KB file. 

In addition, if a whitespace is used in addition to the colon (:), for example "My Custom :Inventory" when attempting to upgrade the Inventory Solution Plug-in Agent to a new version, it will fail with exit code 1603.

Delete the 0 KB files from the folder and the upgrade policy will now run without anerror.  You may not be able to delete the file in Windows, as shown in the following screenshot:

If you receive that, you can run an elevated command prompt and force delete the files in this directory using del *.* /f /q.The /q is for quiet so that you can use a script task to distribute to your end points.