Failed to create trouble ticket - Error Seen When Trying to Create a Service Desk Ticket from the PM Alarm Console
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Failed to create trouble ticket - Error Seen When Trying to Create a Service Desk Ticket from the PM Alarm Console

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Article ID: 254002

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Updated On:

Products

Network Observability Spectrum CA Performance Management CA Service Desk Manager

Issue/Introduction

Spectrum is integrated with CA Performance Management (CAPM) and Spectrum alarms are visible in the PM Portal Alarm Console.

However, when selecting an alarm and clicking the 'Create Ticket' button an error is returned "Failed to Create Trouble Ticket"

Environment

DX NetOps Spectrum & CAPM integrated with CA Service Desk - all currently supported releases

Cause

The AlarmConsole in PM will send the following Rest call to the OneClick Server that is configured for the PM integration:

 /spectrum/restful/createTicket?alarmid=<alarmid>

However, if the OneClick server integrated with CAPM is not also performing the Service Desk integration, then this request will fail.

Resolution

The Service Desk integration needs to be switched to the OneClick which is also integrated with CAPM.  Once this is done, then tickets can be created from the PM Alarm Console.