App Services stops running when there is a change done in CSA
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App Services stops running when there is a change done in CSA

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Article ID: 253865

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Updated On:

Products

Clarity PPM On Premise

Issue/Introduction

If using the JDBC URL with useUrl=true in properties.xml - if you update anything in CSA, and hit save, the application will stop running and an error is thrown. Upon restart it starts working again

STEPS TO REPRODUCE:


1. Start Clarity APP Service and wait for it to complete the startup process.
2. Login to CSA.
3. Make a change to any attributes on Application tab or Security Tab which will refresh connection manager.

Environment

Release : 16.0.3, 16.1.0

Cause

config.TenantConfigurationManager (clarity:none:none:none) Exception occured when trying to construct the Database object for Tenant with id = clarity
java.lang.NullPointerException

at com.niku.union.config.TenantConfigurationBuilder.getTenantDatabase(TenantConfigurationBuilder.java:1044)
at com.niku.union.config.TenantConfigurationBuilder.hasAddedValidTenantDatabase(TenantConfigurationBuilder.java:784)
at com.niku.union.config.TenantConfigurationBuilder.processDefaultTenantInstance(TenantConfigurationBuilder.java:490)
at com.niku.union.config.TenantConfigurationBuilder.isValidTenant(TenantConfigurationBuilder.java:364)
at com.niku.union.config.TenantConfigurationBuilder.createValidTenantConfig(TenantConfigurationBuilder.java:213)
at com.niku.union.config.TenantConfigurationManager.init(TenantConfigurationManager.java:839)

Resolution

DE67313 is fixed in 16.1.1