Schemus Authentication Failure with Exchange online
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Schemus Authentication Failure with Exchange online

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Article ID: 253844

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Updated On:

Products

Email Security.cloud

Issue/Introduction

Schemus is unable to establish a connection using Exchange online.

 

Environment

ESS

Cause

The Exchange Online source was created for Microsoft's EXOv2 PowerShell module which creates a session to Exchange Online.

An updated PowerShell module, EXOv3, is replacing EXOv2 which does not need to establish a session.

 

Resolution

The newer EXOv3 no longer creates a session. If your sync configuration relies on EXOv3, a session is therefore not created and Schemus will report that a session could not be established.

To help with this issue, assuming you're already using Schemus 1.52.03, attached to this article you can find a patch and the respective release notes as well.

The patch mainly addresses and expands the support of EXO, now supporting both EXO V3 and EXO V2.

OR

If instead, the client would prefer to use the older EXOv2 module, they can do this by uninstalling EXOv3 and replacing it with EXOv2 in PowerShell:

     Uninstall-Module -MinimumVersion 3.0.0 -Name ExchangeOnlineManagement
    Install-Module -MaximumVersion 2.0.5 -Name ExchangeOnlineManagement

Attachments

1680268372382__Patch20221028.txt get_app
1680268357942__Patch20221028.zip get_app