search cancel

OpenJDK Upgrade on EMs

book

Article ID: 253806

calendar_today

Updated On:

Products

CA Application Performance Management (APM / Wily / Introscope)

Issue/Introduction

I saw the article where someone asked to upgrade OpenJDK version.  But, the resolution was more about how.

To be clear...

We can upgrade OpenJDK version from EM original install?  We are at 10.7 HF84.

Another question...

Is the OpenJDK installed with an Infrastructure Agent the same as used in the EM install?

    So, what I mean is:  Can we copy the jre folder from an IA install with a newer version of OpenJDK?  To an EM and use it...  I am assuming yes since I used to do the opposite for EPAgents.  But, want to make sure you included all of the lib's needed for the EM.

Environment

Release : 10.7.0

Resolution

In speaking on 10.7 Agents only...

1. APM 10.7 Agents (including APMIA) only support Java 1.8.  They cannot support anything higher than 1.8.

2. If you replace the jre directory of the 10.7 Agent with a higher version than 1.8, we cannot guarantee it will work but we cannot support it.

3. You can upgrade the JVM for 1.8.  For example, if the Agent or EM come with 1.8.0_212 and you want to upgrade to 1.8.0_313, then yes, you can do that.  You can just rename the current jre directory in the Agent or EM and then copy over the new jre directory.