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Apps or integrations that rely on custom dropdown lists no longer working correctly

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Article ID: 253788

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Updated On:

Products

CA Agile Central SaaS (Rally)

Issue/Introduction

Custom apps or integrations that rely on custom dropdown lists are no longer working correctly.  

Cause

Rally recently fixed a long-standing regarding custom dropdown fields that were returning null values for their internal object IDs.  This made it impossible to automate the management of those custom fields, which was very tedious for customers that synchronized data between Rally and third-party systems and had very large dropdown lists, particularly when those dropdown lists were duplicated across multiple work item types.

Because some custom apps and integrations rely on having null values for object IDs, the fix may have unintended consequences on the operation of these apps and integrations.

Resolution

We do have the ability to temporarily toggle the previous custom field behavior to give customers time to resolve remaining issues in their code, and we can toggle that on a subscription or user level.  

This toggle will only be supported until approximately January 15th, after which we may remove the toggle option entirely which will revert the subscription or user back to the behavior where object IDs are present for dropdown list values.

Pleas see the following knowledge base article for guidance on resolving the issue within your App SDK 2.0 custom apps:

https://knowledge.broadcom.com/external/article?articleId=254384