search cancel

Data inconsistencies on Experience View Cards

book

Article ID: 253783

calendar_today

Updated On:

Products

DX Application Performance Management

Issue/Introduction

Customer is observing issue where inconsistency/missing data on Experience View Cards. Some applications are showing data correctly, while others are not showing data correctly. 

There are two applications. App 1 where all the transaction gets started and App 1 makes calls to App 2. All the transaction entry points are on App 1.

In Experience View Cards, customer see data for both App 1 and App 2.

Based on the design of Experience View Cards, the App 2 should not show any data as left most component of all transactions are App 1. 

Environment

Release : 21.3

Cause

it seems like sample transaction trace and error snap shot transaction trace which are being started the entry points are App2. This App 2 is showing data on Experience View Cards for App 2. 

Resolution

Disabled sample transaction trace and error snap shot transaction trace on App 2.